Zeta mistakenly are estimated run time


Advanced search

Message boards : SZTAKI Desktop Grid : Zeta mistakenly are estimated run time

AuthorMessage
Profile Dario666
Avatar
Send message
Joined: Nov 21 13
Posts: 3
Credit: 205,604
RAC: 0
Message 8254 - Posted 3 Dec 2013 23:16:27 UTC

    Last modified: 3 Dec 2013 23:20:31 UTC

    Info from program BoincTasks:

    SZTAKI Desktop Grid 1.01 Riemann Zeta Research Project
    id: 9d7a4224-bb89-4c99-b93f-16e20e2179a3_cb700ad6-a2e5-4013-9f7b-79bdd1dc376a_5ce381f7-bf36-4ef6-a9db-0fb9a269b9ec_0
    run time: 00:23:26 (00:00:14)
    reported: 2013-12-03 23:28:29
    CPU%: 1,00


    This is it WU: http://szdg.lpds.sztaki.hu/szdg/workunit.php?wuid=7056453

    Realistically, this WU run time is 23:26 (1406 seconds), not 14 seconds. CPU core load was 100%, not 1%.
    He was counted on Xeon X5650, and i7 950 run time = 1029 seconds.

    Some Zeta WU incorrectly shows the CPU load!!!
    This results in a much smaller amount of granting credits.
    ____________

    Profile Ananas
    Send message
    Joined: Jul 12 05
    Posts: 222
    Credit: 665,833
    RAC: 0
    Message 8255 - Posted 5 Dec 2013 7:57:21 UTC - in response to Message 8254.

      Last modified: 5 Dec 2013 8:20:54 UTC

      I came here to report the same but I think I know the reason.

      When a result restarts, it uses a proper checkpoint to resume the calculation but it doesn't include the CPU time from before the restart.

      That means that all hosts that do not have "Leave applications in memory while suspended? = YES" set in the computing preferences will report only a fraction of the computing time for any result that has been interrupted.

      As Zetas seem to have a very constant runtime, it might be easier to configure fixed credits for them instead of fixing the problem ;-)

      p.s.: My hosts keep suspended results in memory and when I restarted a core client, the two active Zeta results restarted at the expected percentage but with zero CPU time - and those are my only two Zetas where the total runtime was reported too low. That's what brings me to this conclusion.

      p.p.s.: SLinCA has exactly the same bug so if you decide to fix it instead of using a workaround, you could probably share your solution with them. The two projects seem to be connected somehow.

      Profile Dario666
      Avatar
      Send message
      Joined: Nov 21 13
      Posts: 3
      Credit: 205,604
      RAC: 0
      Message 8262 - Posted 25 Dec 2013 22:17:01 UTC - in response to Message 8255.

        I have "Leave applications in memory while suspended? = YES"


        As Zetas seem to have a very constant runtime, it might be easier to configure fixed credits for them instead of fixing the problem ;-)


        Why have not yet done fixed credits???
        ____________

        adrianxw
        Avatar
        Send message
        Joined: Mar 30 06
        Posts: 8
        Credit: 64,208
        RAC: 14
        Message 8264 - Posted 14 Jan 2014 16:59:12 UTC

          Last modified: 14 Jan 2014 17:07:13 UTC

          This machine is a quad core and typically when looking at the task manager, I see four BOINC processes running using about 25% each. Now, I see four processes "Running" and a host of others waiting. Yet the task manager shows two of the Zeta's running and three other BOINC tasks, (a POEM, a Rosetta and an Asteroids). My Cosmology wu shows as "Running", but not advancing and not using any CPU. Suspending the Zeta tasks in BOINC Manager makes no difference.

          This might be relevant to the other issue in this thread. If the executable is running when BOINC "thinks" it is not, the elapsed run time is going to be out. NNT set for now.

          <edit>
          When the zeta's finished, the Cosmo wu started running again.
          </edit>
          ____________
          Wave upon wave of demented avengers march cheerfully out of obscurity into the dream.

          Profile Dario666
          Avatar
          Send message
          Joined: Nov 21 13
          Posts: 3
          Credit: 205,604
          RAC: 0
          Message 9036 - Posted 15 May 2014 8:58:00 UTC

            Is something will be done in this topic???
            ____________

            Post to thread

            Message boards : SZTAKI Desktop Grid : Zeta mistakenly are estimated run time


            Home | My Account | Message Boards


            Copyright © 2017 SZTAKI Desktop Grid